Skip to content

Teamscale Integration for Eclipse

Before installing the Teamscale Integration for Eclipse, make sure its system requirements are met.

Installing the Plug-in

Depending on your needs, there are several options to install the Teamscale Integration for Eclipse.

For most users, installing the latest version of the plug-in from the Eclipse Marketplace is recommended.

  1. Open the Teamscale Integration for Eclipse solution page at the Eclipse Marketplace.
  2. Drag the Install button from the solution page onto your running Eclipse workspace. This opens the installation wizard.
  3. Follow the instructions of the installation wizard
  4. Restart Eclipse when prompted.

Installing Any Version From the CQSE Website

Unlike the Eclipse Marketplace, the CQSE website offers both the latest version and older versions of the plug-in.

  1. Select Help > Install New Software... from the Eclipse menu bar.
  2. Enter a Work with location.
    • Latest Version: https://downloads.teamscale.com/ide/eclipse/latest/
    • Older Version: https://downloads.teamscale.com/ide/eclipse/vM.N.x/ (replacing M.N by the feature version you need but keeping the .x, e.g., 7.8.x)
  3. Select Teamscale Integration for Eclipse and any optional features you want.
  4. Click Next and follow the instructions of the installation wizard.
  5. Restart Eclipse when prompted.

Installing While Offline

In case you cannot reach the Eclipse Marketplace or CQSE Website during the installation, e.g., due to a security policy, you can perform an offline installation.

  1. Download an archive of the update site from the CQSE website.
  2. Transfer the downloaded archive to your offline computer.
  3. Select Help > Install New Software... from the Eclipse menu bar.
  4. Click Add and the Archive.
  5. Select the downloaded archive.
  6. Select Teamscale Integration for Eclipse and any optional features you want.
  7. Click Next and follow the instructions of the installation wizard.
  8. Restart Eclipse when prompted.

Installing on the Command Line

You can perform the offline installation on the command line as well.

  1. Unzip the downloaded archive.
  2. Use the Eclipse p2 director to install.
    bash
    eclipse -nosplash -application org.eclipse.equinox.p2.director -repository file:///path/to/teamscale-eclipse-update-site -installIU com.teamscale.ide
  3. (If you ever need to uninstall the plug-in, you can use the p2 director as well.)
    bash
    eclipse -nosplash -application org.eclipse.equinox.p2.director -uninstallIU com.teamscale.ide

Don't Use Eclipse's Dropins Mechanism

With the dropins folder, Eclipse provides another way of installing plug-ins. We (and the Eclipse team) discourage using it for installing plug-ins unless you absolutely need to. You won't get error messages with the dropins mechanism as you would with the p2 director, e.g., in case of missing dependencies.

Connecting to Teamscale

After installing the plug-in, you can configure a Teamscale server via the following steps:

  1. Open the Eclipse preferences dialog, navigate to the Teamscale settings (Window > Preferences... > Teamscale) and click on Add
  2. Enter a descriptive name and the URL of the Teamscale server
  3. Enter your Username and Access KeyEclipse Server Settings
  4. Test the connection by clicking on Validate.
  5. Close the dialog by pressing OK.

Enabling the Plugin for Eclipse Project(s)

To connect an Eclipse project to Teamscale and obtain quality data such as findings, perform the following steps:

  1. Open the project properties by right-clicking on the project and selecting Properties.
  2. On the left side, switch to the Teamscale entry.
  3. Click on Enable Teamscale for this project and select the appropriate server.
  4. Click on Automatically configure Teamscale which will automatically identify the correct mapping to the code in Teamscale. Teamscale Project Properties in Eclipse

After connecting a project to Teamscale you can enable the display of findings in the menu bar via Teamscale > Load findings for open files.

Performing Pre-Commit Analysis

The Eclipse plug-in can be used to analyze changes prior to committing them to the repository. This functionality is called pre-commit analysis. The findings of these pre-commits are shown as any other finding in the Findings tool window. The Automatic Pre-Commit Analysis option under the Teamscale tab must be enabled: Teamscale Pre-Commit

The pre-commit analysis is started automatically when you do one of the following actions:

  • Open a file in the editor
  • Switch to an already open file in the editor
  • Save the file currently active editor
  • Save all open files
  • Activate ABAP code

Under the hood, Teamscale treats these changes as a commit on a new, virtual branch: your pre-commit branch. Eclipse will poll the Teamscale server until analysis of this commit is done. Once analysis is finished, Teamscale will show the findings from your pre-commit branch.

Note that, by default, the Teamscale server enforces some limits on the pre-commit branch w.r.t. to the number of files that may be included in each pre-commit. These limits exist so that one overly large pre-commit upload does not disproportionately delay analysis of other commits. More information is available here .

Pre-Commit (plug-in version 9.2 and older)

The Eclipse plug-in can be used to analyze changes prior to committing them to the repository. This functionality is called pre-commit analysis. Only the files changed since the last commit that is present on the Teamscale server are uploaded and analyzed by pre-commit analysis. To compute this delta, Teamscale connects to the version control system configured for the IDE projects. Currently, supported version-control systems are Git and Subversion (using Subversive or Subclipse) You can trigger the pre-commit analysis by selecting Teamscale > Upload Projects for Pre-Commit Analysis from the Eclipse main menu or via the shortcut »Ctrl+9«.

Eclipse reports the findings delta after a few seconds in a balloon as shown in this screenshot and in the Pre-Commit Results view: Pre-commit Analysis Findings Delta

The new findings are also shown in the complete findings list as shown on the left side in the screenshot, however, the Pre-Commit Results view allows you to focus on the new findings.